This project is read-only.

Silverlight 5 Toolkit in Express?

Feb 17, 2012 at 2:48 PM

Does anyone know whether the new SL5Toolkit + SilverSprite combo is available under Visual Web Developer 2010 Express?  I have been able to install VWD, SP1, SL5, and the SL5Toolkit without trouble.  The problem seems to come with the subsequent installation of the Windows Phone SDK (since the SL5 Toolkit requires XNA).  This installation seems to requires an additional SP1 application, but that always seems to fail.  I've tried a few (painfully slow) variations in installation order, and am curious whether anyone else has been successful in getting these tools working under the free versions of Visual Studio.  If it's just me, then maybe a clean install of Windows7 is in order for my machine(?).  Any suggestions will be gratefully received. 

Feb 17, 2012 at 3:02 PM

What is the error you're seeing with SP1?

Feb 17, 2012 at 4:25 PM

Thanks for the quick response.  I was getting the installation failed with error code: (0x80070643), which I tracked to the RIAServices.msi.  After uninstalling that by hand, SP1 completed successfully.  

However, I'm still not able to 1) create a Silverlight 3D Application from VWD: the template is available, but error says: A problem was encountered creating the sub project 'Silverlight3dAppContent'.  The template specified cannot be found.  Please check that the full path is correct., or 2) open a sample like the RolePlayingGame.sln: both RolePlayingGameContentSilverlight.contentproj and RolePlayingGameDataWindows.csproj are failing to load because The project type is not supported by this installation.

Any ideas?

Feb 17, 2012 at 4:44 PM
Edited Feb 17, 2012 at 4:46 PM
Hmm it's probably an Express thing, what happens if you try to create an XNA app? If you can do that you should be able to add its content project manually to a Silverlight project.

Also look through the comments here to see if anything helps:

Feb 17, 2012 at 5:04 PM
billreiss wrote:
Hmm it's probably an Express thing, ...

Disappointing, but thanks for the response.  I did try adding the content project to a silverlight application's csproj file by hand (as described in step4 here:  However, there was no noticeable difference when I opened the project up in VWD 2010 Express.  I do see another post with a similar problem under the SL5Toolkit's Issues.  Btw, I was using the December 2011 version of the SL5Toolkit.

Guess I'll try using the old SilverSprite under SL4 instead.  

Thanks for your help.

Feb 17, 2012 at 5:18 PM

You won't see any visual indication that the project has a linked content project.

Feb 17, 2012 at 5:27 PM

Can you build and run the SilverSprite 5 samples or the Silverlight 5 toolkit 3D samples?
Feb 17, 2012 at 5:50 PM

OK.  Well I played around with it a bit more, and was not even able to get a simple content-less game working.  I also tried the SnakeGameSilverSprite sample which seems to open up alright (no content project in the solution), but then does not do anything.  When I hit F5 within either of these projects, it brings up the browser with a brief Silverlight loading animation which then turns into a blank white browser window.

I'm guessing there's something more wrong with my installations than not being able to open content projects(?).

Feb 17, 2012 at 5:57 PM
Edited Feb 17, 2012 at 5:57 PM

If I'm looking at the correct Silverlight5 Toolkit samples, one folder is labeled "Controls" which builds and runs fine.  I haven't had any luck with projects in the XNA folder: tried "Silverlight Xna Platformer" and "Simple Animation".