This project is read-only.

Horribly stuck trying to port XNA game

Sep 3, 2012 at 4:57 PM
Edited Sep 3, 2012 at 5:02 PM


I'm not a web dev so I am probably just missing something obvious.

I followed the guide for Silversprite 5 on the main page :

My first problem is I don't even see a 3D silverlight project, presumably because I am using the express version of Visual Web Developer.

So assuming a "Silverlight project" is the way to go I then ran into these issues:

1, Following the guide on adding that block of XML (with the correct path) to get content - nothing happened. i.e. no content folder appeared.

2, So I created a simple XNA game with no content needed and tried to follow the rest of the guide. I have only followed the guide "as is" as I wouldn't know what else (if anything) is needed. When I hit F5 I get a blank web page.


Are there any "start to end" guides? I found a really good one for the older silversprite, but it seemed to be using the full version of Visual Web Developer as I was missing half his options.

I need to get this up and running with c# express 2010 and VWD express 2010.

Sep 3, 2012 at 5:55 PM

Do you have Silverlight 5 SDK installed? Sounds like you may still be on Silverlight 4.

Sep 3, 2012 at 6:59 PM

Yeah, I followed the links on the main page, and hadn't had any previous installations since this is the first time I've used silverlight at all.

I even tried some of the samples, they also ran up with a blank web page.

I've just uninstalled everything on the assumption it just won't work in express. I'm going to try the full edition of VS2010 professional tomorrow, will let you know.

The other thing it could be is that I'm using chrome? 

Sep 7, 2012 at 12:39 PM

Well I just set up my dev environment from scratch, using full VS2010 premium, and following the home page guide here to the latter.

*Still* getting a blank web page, even on a little test XNA class I wrote that just renders a rectangle to screen (or should, since it does when running the c#/xna project).

Is there something missing from the guide, particularly the web side, which a web newb like me would be oblivious to?

Sep 7, 2012 at 1:05 PM
Do the samples work? I'd start with one of those and then see what you're doing differently.

Sep 7, 2012 at 3:17 PM


From the samples..

BloomPostProcess - can't compile, loads of compile errors

Marblets - can't compile, won't recognise XNA framework even though it is in references

RolePlayingGame - white page

Platformer - white page

SnakeGame (after vs2010 convert) - Error 1 The font family "Becker Black NF" could not be found. Please ensure the requested font is installed, and is a TrueType or OpenType font. D:\Apps\Silversprite\silversprite\SL5\Samples\SnakeGameSilverSprite\SnakeGameSilverSprite\beckerBlack.spritefont SnakeGameSilverSprite

CardStarterKit - Missing cards framework, can't run


I'm using latest XNA (4.0refresh), VS2010. My XNA games run fine, just not having any luck with the samples above or getting my game into a browser. For info it's this game over 'ere!

Be cool to get it into web.




Sep 7, 2012 at 3:25 PM
Ok let's take a step back and take SilverSprite out of the picture... please try downloading and compiling this sample:
If it doesn't work either then you know it's a Silverlight/XNA issue and the forums would probably be the best place to look for help. If it does work then we can investigate SilverSprite further.
Sep 7, 2012 at 3:49 PM

Getting this:


Error 1 The "ShaderBuildTask.ShaderCompile" task could not be loaded from the assembly ShaderBuildTask, Version=1.0.3072.18169, Culture=neutral, PublicKeyToken=44e467d1687af125.  Confirm that the <UsingTask> declaration is correct, that the assembly and all its dependencies are available, and that the task contains a public class that implements Microsoft.Build.Framework.ITask. D:\VS\Projects\Solar Wind\C#\SolarWind\SolarWind.csproj 175 5 SolarWind


Are there some other prereqs I need on my machine? I literally only installed the stuff here:

.. and XNA 4.0 / VS2010 of course.

Sep 7, 2012 at 4:11 PM

If you want to try it the other way around, here is a sample project I am using to try get it to work

It's on my google drive (file > download)


Basically XNAtest should just draw a rectangle in the upper left.


One other thing to point out, not sure which silversprite DLL I should use, been referencing this one: