This project is read-only.

*FIXED* CornFlowerBlue screen on any computer but my own

May 20, 2010 at 9:26 PM


I've been trying to port my XNA game over to Silverlight and everything is working fine, but when I upload it on my webserver and try to run it on another machine, I just get a corn flower blue rectangle the size of my canvas and nothing happens. This happens both in Internet Explorer and Firefox. Even if I just copy the whole directory onto another machine I get the same error. The other machines I've tried it on all have silverlight installed (tried surfing to other webpages with silverlight and there was no problem).

If I open the error console, I get the following message:

Error: Unhandled Error in Silverlight Application Catastrophic failure (Error 0x1709.  Debugging resource strings are unavailable. See 0x8000FFFF (E_UNEXPECTED))   at MS.Internal.XcpImports.CheckHResult(UInt32 hr)
at MS.Internal.XcpImports.BitmapSource_SetSource(BitmapSource bitmapSource, CValue& byteStream)
at System.Windows.Media.Imaging.BitmapSource.SetSourceInternal(Stream streamSource)
at System.Windows.Media.Imaging.BitmapImage.SetSourceInternal(Stream streamSource)
at System.Windows.Media.Imaging.BitmapSource.SetSource(Stream streamSource)
at SilverArcade.SilverSprite.Graphics.ImageLoader.GetBitmapImage(Stream source)
at Microsoft.Xna.Framework.Graphics.Texture2D..ctor(Stream source, GraphicsDevice device, Vector2 size)
at Microsoft.Xna.Framework.Content.ContentManager.TryLoadPng(String assetName)
at Microsoft.Xna.Framework.Content.ContentManager.LoadTextureFromBitmap(String assetName)
at Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
at RebelEngine.Drawing.loadContent()
at RebelEngine.Game1.LoadContent()
at Microsoft.Xna.Framework.Game.Initialize()
at RebelEngine.Game1.Initialize()
at Microsoft.Xna.Framework.Game.gameLoop_Update(Object sender, SimpleEventArgs`1 e)
at SilverArcade.SilverSprite.GameLoop.CompositionTarget_Rendering(Object sender, EventArgs e)
at System.Windows.Media.CompositionTarget.OnRendering(Object sender, RenderingEventArgs e)
at MS.Internal.JoltHelper.RaiseEvent(IntPtr target, UInt32 eventId, IntPtr coreEventArgs, UInt32 eventArgsTypeIndex)

It seems to be a problem with the loading of images from what I can tell from the cryptic message, but I have no idea what it is. All my content has its build action set to Content.
I'm running out of ideas, can anybody help?

May 21, 2010 at 2:41 AM

How do you build the images? What format are you using? Which content builder and processor?

May 21, 2010 at 2:25 PM

I'm not sure I understand your question. The formats of the images are mostly png's, with one or two bmp's and jpg's. I also have a spriteFont in xnb. Build action is set to content as per the instructions on the main page.

Everything else is default. What am I missing here??


May 23, 2010 at 6:18 AM

That could be the problem. The images need to be in xnb format too if you are using the content manager to load them. I don't know if you can load raw images files using the content manager. I have two solutions, one for building my content, which uses the standard xna libraries and the game using the silverlight libraries. I link the xnb files built in my content solution to my game. I could be wrong here but this is my experience.



May 23, 2010 at 8:26 PM

Can anyone confirm? This seems strange to me because on the main silversprite page it gives instructions on how to load png, bmp, jpegs, etc. Besides, if it were having problems generating the binaries wouldn't I get an error while building? As it is now, it builds and runs fine, the only problem is when I try to open the test page on another computer. Can it be something regarding the hosting? Is there a runtime I'm not including or something?

May 24, 2010 at 4:01 PM

PNGs are fine I use them.

It could be a problem with folders/names of files and stuff like that. I would be happy to help you on teamviewer or something similar.


May 26, 2010 at 2:09 AM

I've seen smilar issues when you don't put the images inside a Content folder. The default folder for the content manager to look for content is inside a Content folder, but this can be overridden. Is there a project we can look at?

May 26, 2010 at 2:01 PM

The images are in a folder called Content, but it's just a regular folder like all others. I'm saying this because in my XNA solution, the folder has a different icon, so maybe it treats it in a different way. Also, some image files are in subdirectories inside the Content folder, might that cause problems? I could put the project on SVN if anybody wants to take a look. Genaga, thanks for the offer, just let me know when you'll be online.

Thanks for your help guys

May 26, 2010 at 3:16 PM

Yeah it shows up as a normal folder. It depends if you have changed any settings too. You might have removed the rootdirectory or anything really.


Contact me via email at or msn on

May 26, 2010 at 4:27 PM

Ok now we have a new symptom to go on. Genaga was kind enough to help out and we realized that he is able to play the game, no problem. Here is the link if anybody else would like to try it out.

Still, trying it out on other computers yields the blue box I mentioned in my first post. Considering that the only computers that its worked on are developers', I'm wondering if there is some sort of runtime I'm missing.

Here are the files that are currently in the directory of the html I linked to:




JurassicSilverlight.xap (actual build of the game)

JurassicSilverlightTestPage.html (this is the link i posted)



Any ideas?

May 30, 2010 at 3:29 PM

Ok, fixed. Apparently it was a problem with my silverlight instalation. In the project properties I only had the option of compiling for silverlight 3. After installing silverlight 4 and compiling for that, everything is working fine. Thanks for everyone for their help.